Ad Radar
Subscribe
Subscribe
> > > > >
Problem with my 2003 Ram 2500 4X4 Hemi

Problem with my 2003 Ram 2500 4X4 Hemi

  
Truckin Magazine
Item Posts    Sort Order

Problem with my 2003 Ram 2500 4X4 Hemi

 
capt.raymond capt.raymond
New User | Posts: 2 | Joined: 07/13
Posted: 07/04/13
08:50 AM

Hi all, I just joined up and really like your website. I Love my truck but I think I have the Holy Grail of a problem with my truck according to the service techs and engineers that are dealing with this issue as we speak. Approx 3 1/2 weeks ago I was just running some errands and my truck started to lose power and was shaking and my gas pedal was not responding at all so I limped off the road to a parking lot waiting for it to self correct and it never did. So I turned off the ignition, waited a few mins and restarted it and it seemed to run as nothing happened for a couple miles then it happened again so somehow i slowly limped back home and got it back in my driveway. I made some calls and was told that it may be my electronic throttle body and to try and replace it, so i did, $250 some dollars later I got the part from a Dodge dealership 10 mins from my house. After installing it the truck ran fine for about 4 miles then it all happened again so I decided to take it to the Dodge dealership. After doing some testing the service advisor called and asked me where I purchased the throttle body so I said from your parts dept, he said the tests are showing it is bad so he warrantied the part out at no cost to me, great for that but after installing a new one the tech drove the truck and my problem came back. A few days later the service guy calls me and says that the tests are indicating a bad PCM - Powertrain Control Module? I said ok how much and was told $1100.00 so I said ok, when they did a nationwide search for a PCM there database turned up ZERO! So, they got Crysler corp involved and a few days later I had a new one installed. The techs reprogrammed the system and all looked fine so off they went on a test drive and it happened again? My truck has been there over 3 weeks and the latest info I received yesterday was that during one of the diagnostic tests it was showing a 5 volt short somewhere in the electrical system and for the last week every time they run a test they get different fault codes? Even the engineers are stumped, I was told that they are going to have to ring out every single wire in the system to try and find out what the hell is wrong with my truck.
This is turning out to be a pain in my ass! Is there anybody that can give me any advise on this type of problem? I only have 102,000 miles on this 2003 truck, and I could use any help any of you could think of. Im sorry about such a long post but it was the only way I could explain what I went and am going through right now. My truck could possibly be at the dealer for another few weeks until they can solve this issue and I need my truck back, it sucks not having wheels right now. I am hoping and looking forward to any comments or ideas you all may have for me. The service advisor told me that the odds of this happening to a truck is almost like the odds of playing the lotto. When he told me that, it did no justice to the way it made me feel. So right now im into it approx $1300.00 not knowing how much more my bill will be.  

capt.raymond capt.raymond
New User | Posts: 2 | Joined: 07/13
Posted: 07/06/13
11:23 PM

Hi all, looks like i have had a few hundred views on this problem. Is there anybody that may be familiar on this that can reply to my call for some type of help? I could use any info anybody has to offer at this point. Im heading back to the dealership first thing monday morning to try and find out why their techs and engineers have had my truck for over 3 weeks!

Thanks again,
Raymond  

waynep712222 waynep712222
New User | Posts: 9 | Joined: 03/13
Posted: 07/09/13
10:18 AM

you just had to wait for the RIGHT person to read your post..

i have a few things...
since replacing the computer for 1100 bucks.. are they going to charge you for that NON FIX????

did it set any codes....  

and i would like you to print this jpg image of the voltage drop test.. either you take a volt meter and run the test.. or stand there and watch them run it..  post results by number

1....

2....

3....

4....


image below this line~~~~~~~~~~~~~~~~~

Voltagedroptesting

image above this line~~~~~~~~~~~~~~~~~ please print this..

i had somebody call me today with charging system issues..  they found on test 3 between the battery negative and the body 1.2 volts.. and an additional test between the alternator output and the positive battery 1.9 volts..  where there should be tiny fractions of a volt... 0.04 is 4/100th of a volt. and is the resistance of the copper wire in a properly connected circuit..  0.02 is 2/100th of a volt..

so instead of this tiny fraction of a volt.. he is getting over 1.2 and then 1.9 volts between parts on the same side of the circuit .. showing that there are connection issues. .  

waynep712222 waynep712222
New User | Posts: 9 | Joined: 03/13
Posted: 07/09/13
10:22 AM

why is the voltage drop an issue.. this is a computerized truck... even with non computerized cars..

parts are grounded to various sections of the car..

since electrons flow from Negative to Positive.. if you have a bad ground.. you may not have enough electrons or you might have TOO MANY electrons and the voltage expected by the PCM will be wrong and it will shut down. into default mode.. as it just does not know what to do..  

waynep712222 waynep712222
New User | Posts: 9 | Joined: 03/13
Posted: 07/09/13
10:41 AM

lastly.. i know a guy who put a 2003 hemi in their jeep.. must have spent 50 grand on it..  

guess what.. it had terrible issues like you describe.. making it a UNDRIVEABLE..  i sent him the voltage drop test.. his mechanics on staff did not think it had anything to do with the issue..

i said i would come out if it did not find an issue.. i ask where it all was grounded..  he said a stud on the firewall.. i said thats where i will start if you need me.. taking them all off and wire brushing them.. then reinstalling them..

2000 Jeep Chrokee Sportinnerfenderground Zps546de9da

2000 Jeep Cherokee Sport Firewallground Zps7f7fb91c

2001Rangerfirewallgroundstrap

this is the WRONG place to hook the engine to firewall ground connection..

2003 Jeep Liberty Firewall Ground Wrong1

2004 Jeep Liberty Firewall Grounds




on the positive side...

2000 Jeep Cheorkee Sport PDC Terminal Zps9b04ceb4